<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div style="font-family:times new roman,new york,times,serif;font-size:12pt"><div>Hi,<br><br>Setting PTLIBDIR=/lib/i386-linux-gnu solves the problem.<br><br>Thank you all!<br></div><div style="font-family:times new roman, new york, times, serif;font-size:12pt"><br><div style="font-family:arial, helvetica, sans-serif;font-size:13px"><font face="Tahoma" size="2"><hr size="1"><b><span style="font-weight: bold;">De:</span></b> Jan Willamowius <jan@willamowius.de><br><b><span style="font-weight: bold;">Para:</span></b> h323plus@lists.packetizer.com<br><b><span style="font-weight: bold;">Enviado:</span></b> miť,22 junio, 2011 09:43<br><b><span style="font-weight: bold;">Asunto:</span></b> Re: [h323plus] Compiling PTLib 2.10.1 in Ubuntu 11<br></font><br>Hi,<br><br>I just tried it and on Ubunto 11.04 (32bit) and I had no trouble<br>compiling PTLib 2.10.1.<br><br>I have a
 minimal install of Ubuntu and added pkg-config, automake, flex,<br>bison and gcc, but I think that was it. The I set set PTLIBDIR, did a ./configure<br>and make optnoshared. No problems, I also tried a few of the samples.<br><br>If you continue to have problems with PTLib, you should post on the<br>OPAL mailinglist (<a ymailto="mailto:opalvoip-user@lists.sourceforge.net" href="mailto:opalvoip-user@lists.sourceforge.net">opalvoip-user@lists.sourceforge.net</a>) to reach the<br>PTLib developers.<br><br>Regards,<br>Jan<br><br>-- <br>Jan Willamowius, Founder of the GNU Gatekeeper Project<br>EMail  : <a ymailto="mailto:jan@willamowius.de" href="mailto:jan@willamowius.de">jan@willamowius.de</a><br>Website: <a href="http://www.gnugk.org" target="_blank">http://www.gnugk.org</a><br>Support: <a href="http://www.willamowius.com/gnugk-support.html" target="_blank">http://www.willamowius.com/gnugk-support.html</a><br><br>JF NP wrote:<br>> Hi again:<br>>
 <br>> I've found these libs installed: <br>> /lib/i386-linux-gnu/libpthread-2.13.so  /lib/i386-linux-gnu/libpthread.so.0<br>> <br>> So I've run: ./configure --libdir=/lib/i386-linux-gnu<br>> <br>> But I still get the "must have pthreads!" error.<br>> <br>> Regards,<br>> <br>> <br>> <br>> <br>> ________________________________<br>> De: JF NP <<a ymailto="mailto:jfnp090274@yahoo.es" href="mailto:jfnp090274@yahoo.es">jfnp090274@yahoo.es</a>><br>> Para: Piyush Verma <<a ymailto="mailto:piyush.pv@gmail.com" href="mailto:piyush.pv@gmail.com">piyush.pv@gmail.com</a>><br>> CC: <a ymailto="mailto:h323plus@lists.packetizer.com" href="mailto:h323plus@lists.packetizer.com">h323plus@lists.packetizer.com</a><br>> Enviado: miť,22 junio, 2011 08:35<br>> Asunto: Re: [h323plus] Compiling PTLib 2.10.1 in Ubuntu 11<br>> <br>> <br>> Thank you, Piyush. But it seems that I've that installed
 already:<br>> <br>> sudo apt-get install libpthread-stubs0-dev<br>> [sudo] password for xxxxxxx: <br>> Reading package lists... Done<br>> Building dependency tree       <br>> Reading state information... Done<br>> libpthread-stubs0-dev is already the newest version.<br>> libpthread-stubs0-dev set to manually installed.<br>> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.<br>> <br>> <br>> <br>> <br>> ________________________________<br>> De: Piyush Verma <<a ymailto="mailto:piyush.pv@gmail.com" href="mailto:piyush.pv@gmail.com">piyush.pv@gmail.com</a>><br>> Para: JF NP <<a ymailto="mailto:jfnp090274@yahoo.es" href="mailto:jfnp090274@yahoo.es">jfnp090274@yahoo.es</a>><br>> CC: <a ymailto="mailto:h323plus@lists.packetizer.com" href="mailto:h323plus@lists.packetizer.com">h323plus@lists.packetizer.com</a><br>> Enviado: miť,22 junio, 2011 03:42<br>> Asunto: Re:
 [h323plus] Compiling PTLib 2.10.1 in Ubuntu 11<br>> <br>> Hi,<br>> <br>> Try to install  libpthread-stubs0-dev.<br>> <br>> sudo apt-get install libpthread-stubs0-dev.<br>> <br>> pthread stubs not provided by native libc, development files.<br>> <br>> <br>> <br>> -- <br>> Thanks & Regards<br>> <br>> Piyush Verma<br>> <br>> <br>> <br>> <br>> <br>> <br>> <br>> On Tue, Jun 21, 2011 at 11:14 PM, JF NP <<a ymailto="mailto:jfnp090274@yahoo.es" href="mailto:jfnp090274@yahoo.es">jfnp090274@yahoo.es</a>> wrote:<br>> <br>> Hi,<br>> ><br>> >I'm trying to build PTLib 2.10.1 in Ubuntu 11, and I have a problem with <br>> >pthreads. When I run ./configure, I get the following output:<br>> ><br>> ><br>> >checking for pkg-config... /usr/bin/pkg-config<br>> >checking pkg-config is at least version 0.9.0... yes<br>> >checking for gcc...
 gcc<br>> >checking whether the C compiler works... yes<br>> >checking for C compiler default output file name... a.out<br>> >checking for suffix of executables... <br>> >checking whether we are cross compiling... no<br>> >checking for suffix of object files... o<br>> >checking whether we are using the GNU C compiler... yes<br>> >checking whether gcc accepts -g... yes<br>> >checking for gcc option to accept ISO C89... none needed<br>> >checking for g++... g++<br>> >checking whether we are using the GNU C++ compiler... yes<br>> >checking whether g++  accepts -g... yes<br>> >.10figure: PTLib version is 2<br>> >checking build system type... i686-pc-linux-gnu<br>> >checking host system type... i686-pc-linux-gnu<br>> >checking target system type... i686-pc-linux-gnu<br>> >checking for swab... no<br>> >configure: OSTYPE set to linux<br>> >configure:
 OSRELEASE set to "2.6.38-8-generic"<br>> >configure: MACHTYPE set to x86<br>> >configure: gcc version is 4.5.2<br>> >checking checking if pragma implementation should be used... no<br>> >checking checking if precompiled headers available... no<br>> >checking how to run the C++ preprocessor... g++ -E<br>> >checking for grep that handles long lines and -e... /bin/grep<br>> >checking for egrep... /bin/grep -E<br>> >checking for ANSI C header files... no<br>> >checking for sys/types.h... no<br>> >checking for sys/stat.h... no<br>> >checking for stdlib.h... no<br>> >checking for string.h... no<br>> >checking for memory.h... no<br>> >checking for strings.h... no<br>> >checking for inttypes.h... no<br>> >checking for stdint.h...  no<br>> >checking for unistd.h... no<br>> >checking whether byte ordering is bigendian... yes<br>> >configure:
 Default extension for C++ files is cpp<br>> >checking if compiler accepts -felide-constructors... no<br>> >checking if linker accepts -Wreorder... no<br>> >checking if debug build accepts -g3 -ggdb -O0... no<br>> >checking if compiler uses RTTI by default... no<br>> >checking size of int... 0<br>> >checking for long double with more range or precision than double... no<br>> >checking for flex... /usr/bin/flex<br>> >checking for ar... ar<br>> >checking for bison... /usr/bin/bison<br>> >checking if readdir_r has 2 parms... no<br>> >checking if readdir_r has 3 parms... no<br>> >configure: PTRACE and all trace logging included<br>> >configure: Using ANSI C++ bool for PBoolean: (PFalse=false PTrue=true)<br>> >checking for recvmsg... no<br>> >checking for IPV6_ADD_MEMBERSHIP... no<br>> >checking for NetLink support... no<br>> >checking if using STL streams...
 no<br>> >checking if atomic integer available...  no<br>> >checking if Unix semaphores are available... no<br>> >checking if named semaphores are available... no<br>> >configure: WARNING: This host does not support semaphores which are essential<br>> >configure: WARNING: to implement 'critical sections'. This feature was added<br>> >configure: WARNING: in PWLib 1.7.0 and improves the stability of multithreaded<br>> >configure: WARNING: programs. This feature has been disabled for this host<br>> >checking for pthread_create in -lpthread... no<br>> >configure: error: must have pthreads!<br>> ><br>> >But if I do: whereis pthread.h<br>> >I get: /usr/include/pthread.h<br>> ><br>> >So it seems that pthreads is installed. What am I doing wrong? <br>> ><br>> >Regards, and thank you in advance for your help.<br>> ><br>> ><br><br><br></div></div>



</div></body></html>