[h323plus] OpenSSL 1.1

Jan Willamowius jan at willamowius.de
Fri Apr 27 06:35:59 EDT 2018


Dear community,

currently H323Plus depends on OpenSSL 1.0 to enable the full
functionality. Adapting password checksums to the OpenSSL 1.1 API was
easy and is already in the repository, but moving the media encryption
code to 1.1 is very hard. 

Many Linux distributions are moving to OpenSSL 1.1 and its starting
to get complicated to build GnuGk with media encryption since other
shared libraries depend on OpenSSL 1.1 now.

I'm looking for sponsors to help fund the development work to fully
move H323Plus and all the applications that depend on it (GnuGk etc.)
to OpenSSL 1.1.

If you or your company can help. Please send me an email.

Regards,
Jan

-- 
Jan Willamowius, Founder of the GNU Gatekeeper Project
EMail  : jan at willamowius.de
Website: https://www.gnugk.org
Support: https://www.willamowius.com/gnugk-support.html

Relaxed Communications GmbH
Frahmredder 91
22393 Hamburg
Geschäftsführer: Jan Willamowius
HRB 125261 (Amtsgericht Hamburg)
USt-IdNr: DE286003584



More information about the h323plus mailing list