[h323plus] OpenMCU not using video codecs

Victor Zanozin vxz at bby.com.au
Thu Nov 24 16:24:03 EST 2011


Hi Simon,

I've installed libavcodec-dev and libavformat-dev, but I can't seem to find libavcore-dev for Ubuntu Oneiric... The closest I could find was http://ftp.br.debian.org/debian-multimedia/pool/main/f/ffmpeg-dmo/libavcore-dev_0.6.1+svn20101128-0.2squeeze2_i386.deb, would that work?

Victor Zanozin  |  Help Desk Support  |  BBY Limited  |  Level 17, 60 Margaret St Sydney NSW 2000  |  D: +61 2 9226 0261  |  F: +61 2 9226 0066  |  E: vxz at bby.com.au  |  W: www.bby.com.au
Disclaimer: Click here<http://www.bby.com.au/Disclaimer> for important terms relating to this communication, or alternatively click on the Disclaimer link on our website.


________________________________
From: h323plus-bounces at lists.packetizer.com [mailto:h323plus-bounces at lists.packetizer.com] On Behalf Of Simon Horne
Sent: Friday, 25 November 2011 6:18 AM
To: 'Miller, Michael B'
Cc: h323plus at lists.packetizer.com
Subject: Re: [h323plus] OpenMCU not using video codecs

Sorry
It should be avcore-dev
So it should look like
sudo apt-get install libavcodec-dev libavformat-dev libavcore-dev

Thanks

Simon

From: Miller, Michael B [mailto:myk at illinois.edu]
Sent: 25 November 2011 04:28
To: Simon Horne
Subject: Re: [h323plus] OpenMCU not using video codecs

Simon,

In the H.263 instructions, you list libavcodec-dev twice.  Is that correct? or is there a 3rd dependency?

thanks,
Michael Miller
System Engineer
NCSA
217 649 0747
"If you're clear in your vision and trust the people in your team with clear objectives, they will invariably do their best to achieve everything desired, and usually deliver everything you could have hoped for and even more." -Paul Debevec

On Nov 24, 2011, at 12:14 PM, Simon Horne wrote:


Victor

Video codecs are plugins (external libraries) and H.263 and H.264 have dependencies that are required before they will build.

H.261
No dependencies. Make sure your copy the plugin to the same directory (or subDir) as the executable or set the PTLIBPLUGINDIR environmental variable to point to where the *plugin.so resides.

H.263
Dependency FFMPEG
for debian based systems
sudo apt-get install libavcodec-dev libavformat-dev libavcodec-dev
Goto H.261

H.264
Dependency FFMPEG (decode) and X264 (encode)
for debian based systems
sudo apt-get install libx264-dev
Goto H.263


Rerun ./configure and the codecs should then be available. Do a Make and the the *plugin.so should be in the h323plus/plugins directory. Copy them from there.
H.264 also has a *helper.so file which needs to be copied as well. This *MUST* be in the same directory as the executable. It does not understand the PTLIBPLUGINDIR environmental variable.

You should then be good to go.

To debug the codecs set the environmental variable PTLIB_TRACE_CODECS=4
You should see in the console the initial tests to check that all the dependencies are found at startup.

Simon



From: h323plus-bounces at lists.packetizer.com<mailto:h323plus-bounces at lists.packetizer.com> [mailto:h323plus-bounces at lists.packetizer.com] On Behalf Of Victor Zanozin
Sent: 24 November 2011 16:41
To: h323plus at lists.packetizer.com<mailto:h323plus at lists.packetizer.com>
Subject: [h323plus] OpenMCU not using video codecs

Hi everyone,

I'm having a lot of trouble setting up an OpenMCU server on either FreeBSD/Ubuntu (Ubuntu preferred).

On FreeBSD, after all the packages are installed I am seemingly limited to H.261 - The endpoints are capable of H.263/264, however I cannot get OpenMCU to use this codec.

On Ubuntu (my preferred system) OpenMCU preferences report the use of the G711 audio codecs, but do not even use the H.261 video codecs. There is no video output to any of the endpoints.

I think it might have to do with the codec installation on Ubuntu - How can I check if these are installed properly?

When I try to configure the h323plus install, I get the following:

=================== Plugin configuration ======================
prefix                           : /usr/local
exec_prefix                      : ${prefix}
libdir                           : ${exec_prefix}/lib
Audio Codec plugin install dir   : ${libdir}/opal-1.23.0/codecs/audio
Video Codec plugin install prefix: ${libdir}/opal-1.23.0/codecs/video
LID plugin install prefix        : ${libdir}/opal-1.23.0/lid
FAX plugin install prefix        : ${libdir}/opal-1.23.0/fax

                              GSM :  yes (internal)
                          gsm-amr :  yes
                             iLBC :  yes (internal)
                            Speex :  yes (internal, version 1.1.11.1)
                            LPC10 :  yes
                            G.726 :  yes
                        IMA_ADPCM :  yes
                              SBC :  no

                           H.261  :  yes
                           H.263  :  no (ffmpeg version)
                     H.263/H.263+ :  no
                           H.264  :  no
                          THEORA  :  yes
                    MPEG4 Part 2  :  no
                            CELT  :  no

                     SpanDSP FAX  :  no

                            CAPI  :  no
           Quicknet xJACK support :  no
         Voicetronics VPB support :  yes

                         OS Type  :  linux-gnu
                    Machine Type  :  i686

If all settings are OK, type make and make install
========================================================

Level 5 debug logs show:

  0:00.034                      OpenMCU MCU     Codecs (in preference order):
Table:
   G.711-ALaw-64k <1>
   G.711-uLaw-64k <2>
   UserInput/hookflash <3>
   UserInput/basicString <4>
   UserInput/dtmf <5>
   UserInput/RFC2833 <6>
   UserInput/Navigation <7>
   UserInput/Softkey <8>
   UserInput/PointDevice <9>
   UserInput/Modal <10>
Set:
   0:
     0:
       G.711-ALaw-64k <1>
       G.711-uLaw-64k <2>
     1:
     2:
       UserInput/hookflash <3>
       UserInput/basicString <4>
       UserInput/dtmf <5>
       UserInput/RFC2833 <6>
       UserInput/Navigation <7>
       UserInput/Softkey <8>
       UserInput/PointDevice <9>
      UserInput/Modal <10>

There seem to be no video codecs being found or loaded... I'm running the latest version of everything from the h323plus.org<http://h323plus.org> site, OpenMCU 2.2.5-1, h323plus 1.23.0.

I've added what I believe to be the video codec directories in the following locations (yes, it's a mess):

/usr/local/lib/opal-1.23.0/plugins/video
/usr/local/lib/opal-1.23.0/codecs/video
/usr/local/lib/opal-1.23.0/codecs/video/video
/usr/local/lib/opal-1.23.0/temp/plugins/video
/usr/local/lib/opal-1.23.0/video
/usr/lib/ptlib/plugins/video
/usr/lib/ptlib/codecs/video
/usr/lib/ptlib/video
/usr/lib/ptlib-2.4.5/plugins/video

The contents of these are:

root at OpenMCU:/usr/lib/ptlib/codecs/video# ls
common  H.261-vic  H.263-1998  H.263-ffmpeg  H.264

I'm also seemingly missing the H.264 codec:

configure: h264 support disabled due to disabled dependency HAVE_H264_DECODER
checking enable H.264 support... no

Can anyone shed some light on this?

Thanks!

Victor


*****************************************************************************

This footnote confirms that this email message has been scanned

by MessageLabs Email Security Service for the presence of computer viruses.

BBY IT Support + 61 2 9226 0123

*****************************************************************************
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.packetizer.com/pipermail/h323plus/attachments/20111125/40fa9955/attachment-0002.html>


More information about the h323plus mailing list