[h323plus] Need help to run oh323tut application using ALSA

Simon Horne s.horne at packetizer.com
Mon Nov 21 01:18:21 EST 2011


Abdul Moiz

 

Sorry for the delay in replying. I have been travelling.

 

In your derived OpenAudioChannel

PBoolean H323EndPoint::OpenAudioChannel(H323Connection & connection,PBoolean
isEncoding, unsigned bufferSize, H323AudioCodec & codec);

 

The second parameter isEncoding specifies the direction of the channel (true
= transmit, false=receive). 

This function is called once for each direction.

To only transmit or receive then return false for the function for the
direction you do not wish to open.

 

Simon

 

From: ABDUL MOIZ [mailto:abdulmoiz786 at gmail.com] 
Sent: 17 November 2011 19:49
To: Simon Horne
Subject: Re: [h323plus] Need help to run oh323tut application using ALSA

 

Hi,

        Is it possible to enable opening of only one audio channel say for
transmitting in caller application and only one audio channel for receving
in listener application?

In the present scenario, there are 2 audio channels being opened, one for
transmitting and the other for receiving.Can I configure to open only one
channel for transmitting/receiving?

Regards
Abdul Moiz

On Fri, Nov 11, 2011 at 4:53 PM, Simon Horne <s.horne at packetizer.com> wrote:

Try

simple -h

To bring up the switch list

See

"P-prefer:"

 

So simple -ln -PH.263,G.711

Will make H.263 and G.711 default

 

Simon

 

 

From: ABDUL MOIZ [mailto:abdulmoiz786 at gmail.com] 
Sent: 11 November 2011 17:15


To: Simon Horne
Subject: Re: [h323plus] Need help to run oh323tut application using ALSA

 

Hi,
       Can you please tell me how to change the default audio/video codecs
in simph323 application.


Thanks,
Abdul Moiz

On Thu, Nov 10, 2011 at 2:54 PM, Simon Horne <s.horne at packetizer.com> wrote:

Apply this patch

http://h323plus.cvs.sourceforge.net/viewvc/h323plus/h323plus/samples/simple/
main.cxx?r1=1.4
<http://h323plus.cvs.sourceforge.net/viewvc/h323plus/h323plus/samples/simple
/main.cxx?r1=1.4&r2=1.5> &r2=1.5

 

Enable environmental variable

PTLIB_TRACE_CODECS=4

When running simple you will be able see the directories it searches for the
X264 helper. 

 

Simon

 

From: h323plus-bounces at lists.packetizer.com
[mailto:h323plus-bounces at lists.packetizer.com] On Behalf Of ABDUL MOIZ
Sent: 10 November 2011 17:07
To: h323plus at lists.packetizer.com; s.horne at packetizer.com


Subject: Re: [h323plus] Need help to run oh323tut application using ALSA

 


Hi,
          I have copied h26x_pwplugin.so and h264_video_pwplugin_helper
files in my simph323 application directory and when I run the applications, 

after call establishment ,

the "listener" application is hanging up at the function
((PVideoInputDevice
*)device)->GetDeviceCapabilities(deviceName,deviceDriver,&videoCaps)

and the "caller" application is giving the error:
H323> ERROR: H.264 plugin couldn't find GPL process executable:
h264_video_pwplugin_helper

and therefore video channel is not being opened.

Can you please help me to solve the above problem.

Regards
Abdul Moiz

On Thu, Nov 3, 2011 at 8:55 PM, Simon Horne <s.horne at packetizer.com> wrote:

 

You build the plugin codecs in the plugin directory that is part of
h323plus.

Ie h323plus/plugins 

 

Look for h26x_ptplugin.so

 

Simon

 

 

From: ABDUL MOIZ [mailto:abdulmoiz786 at gmail.com] 
Sent: 04 November 2011 00:05


To: Simon Horne
Subject: Re: [h323plus] Need help to run oh323tut application using ALSA

 


Hi,
          

On Thu, Nov 3, 2011 at 5:51 PM, Simon Horne <s.horne at packetizer.com> wrote:

You build the plugin codecs in the plugin directory. They are separate
files. Look for *_ptplugin.so

 

 

        I have alsa and v4l2 plugin file names as alsa_pwplugin.so and
v4l2_pwplugin.so respectively.
I have copied the above plugin files into my application directory, but
still video tranfers is not happening.

 

Apply this patch

http://h323plus.cvs.sourceforge.net/viewvc/h323plus/h323plus/samples/simple/
main.cxx?r1=1.4
<http://h323plus.cvs.sourceforge.net/viewvc/h323plus/h323plus/samples/simple
/main.cxx?r1=1.4&r2=1.5> &r2=1.5



  By applying above patch, the code is not being hanged up now.But still
video transfer is not happening.


After some debugging of code, I have found that the function 
SimpleH323EndPoint::OpenVideoChannel(...) is not being called.
Thereby video channel is not being created and video transfer is not
happening.
So I want to know whether
simph323 application (out of the box) does video transfers?

                                       (or)

Do I need to add the videocodec interface in the code so that the above said
function may be called?
If so can you please send me the required code snippets.

Thanks
                 

 

Simon

 

From: ABDUL MOIZ [mailto:abdulmoiz786 at gmail.com] 
Sent: 03 November 2011 19:54


To: Simon Horne
Subject: Re: [h323plus] Need help to run oh323tut application using ALSA

 

Hi,

      I have found that v4l2 plugin is already built.And I have used the
variable PTLIBPLUGINDIR to point it to the directory containing plugin.
But still, I am unable to get Video transfers.
When I started debugging, I found that the simph323 application program flow
is being hanged up at the function call 
PVideoInputDevice::GetDeviceCapabilities(devices[0],inputDriverName,&caps)  
in main.cxx file.
Can you please help me in giving correct options while executing the
application.
or any other suggestions to get Video transfers

Below are the options I am giving presently

$ ./simph323 -l -n -u listener -i 192.1.4.1 -x 6000 -v V4L2

$ ./simph323 -n -u caller -i 192.1.4.2 -x 5000 -v V4L2
listener at 192.1.4.1:6000


My system is X86 , running ubuntu 10.04


Regards,
Abdul Moiz


On Thu, Nov 3, 2011 at 12:41 PM, Simon Horne <s.horne at spranto.com> wrote:

Video is enabled via plugins, Build the plugins and place them in the same
directory as the application.

You can also use the environmental variable PTLIBPLUGINDIR to point to the
directory where the video/audio plugins are.

 

Simon

 

From: ABDUL MOIZ [mailto:abdulmoiz786 at gmail.com] 
Sent: 03 November 2011 16:54
To: Simon Horne; h323plus at lists.packetizer.com


Subject: Re: [h323plus] Need help to run oh323tut application using ALSA

 

Hi,

          I am using simph323 application (i.e running two instances one as
caller and the other as listener) and able to transfer only "Audio".
Is it possible to transfer "Video" and "Data" also using simph323
application and if so how to give the command line options for the 2
instances (i.e caller and listener)
Or else can anybody suggest me if there is any better application/example to
transfer Audio,Video and Data simultaneously.

Regards,
Abdul Moiz

On Wed, Nov 2, 2011 at 3:41 AM, Simon Horne <s.horne at packetizer.com> wrote:

Abdul Moiz

 

There are no specific ALSA examples.

However there are a number of same applications contained in the
Applications download from the website.

 

Simon

 

From: ABDUL MOIZ [mailto:abdulmoiz786 at gmail.com] 
Sent: 01 November 2011 12:39
To: Simon Horne
Subject: Re: [h323plus] Need help to run oh323tut application using ALSA

 

Hi simon,
 
         Thanks for your response.

    I am a beginner in this field.
I am looking for sample examples/applications which establishes H.323 call
and tranfers video,audio and data across 2 systems.
Can you please tell me where can I find the latest sample applications (for
Video,Audio and Data) or the related information/document for development of
such applications


Regards,
Abdul Moiz

On Fri, Oct 28, 2011 at 8:34 PM, Simon Horne <s.horne at packetizer.com> wrote:

Abdul Moiz

Oh323tut is getting quite old but here are some tips to get and set the
Audio Driver and Device Name     


Get the drivers
PStringArray names = PSoundChannel::GetDriverNames();

Get the devices
PString DefaultAudioDriver = names[0];
PStringArray playDevices =
PSoundChannel::GetDeviceNames(DefaultAudioDriver,PSoundChannel::Player);
PStringArray recDevices =
PSoundChannel::GetDeviceNames(DefaultAudioDriver,PSoundChannel::Recorder);

Enumerate the devices
for (PINDEX i = 0; i < playDevices.GetSize(); i++) {
       cout << playDevices[i] << endl;
}

To set the driver call these functions
PBoolean H323EndPoint::SetSoundChannelPlayDriver(const PString & name)
PBoolean H323EndPoint::SetSoundChannelRecordDriver(const PString & name)

To set the device call these functions
PBoolean H323EndPoint::SetSoundChannelPlayDevice(const PString & name)
PBoolean H323EndPoint::SetSoundChannelRecordDevice(const PString & name)

Simon


From: h323plus-bounces at lists.packetizer.com
[mailto:h323plus-bounces at lists.packetizer.com] On Behalf Of ABDUL MOIZ
Sent: 28 October 2011 17:15
To: h323plus at lists.packetizer.com
Subject: [h323plus] Need help to run oh323tut application using ALSA


Hi,

        I have downloaded the source code of "h323plus core"(version:1.23.0)
and "PTlib"(version:2.10.1) from the link:

     http://www.h323plus.org/source/

     on my X86 Desktop system running ubuntu 10.04


   I have followed the tutorial given at link

      http://toncar.cz/openh323/tut/index.html

   I am able to compile both the source codes without any problems.

  Then I have downloaded and compiled "oh323tut" (version 1.1-1) source code
from the link below:

       http://toncar.cz/openh323/tut/files.html

  I have got simph323 installed on my system using

  $ sudo apt-get install simph323


 Now when I try to run oh323tut application and simph323 application (in
separete terminals) using the commands below:

$ ./oh323tut -f audio.wav -n -u 320
$ simph323 -n -u 321 320 at 127.0.0.1:1820

   I am getting the following problem:

 H323> Could not open sound device Default - Check permissions or full
duplex capability.


  Can anybody please help to  solve the above problem.


 Regards

 

 

 

 

 

 

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.packetizer.com/pipermail/h323plus/attachments/20111121/61f65ab6/attachment-0002.html>


More information about the h323plus mailing list