[h323plus] OpenH323 version is 1.22.0 Compilation problems

Jose P. Espinal jpe at slackware-es.com
Fri Jan 14 11:00:58 EST 2011

Hello List,

I'm not sure this is the correct list to post this message, but 
searching on Google was not of much help.

NOTE: Please feel free to point me to the correct place to search (in 
the case that this is not the correct list for this)

I'm trying to install OpenH323 1.22.0 on Slackware Linux 13.0,
I installed (without problems) ptlib-2.8.3

In the moment I run the ./configure script inside h323plus-1.22.0/ 
directory, it ends with the following error:

checking for /usr/include/ptlib/version.h... no
Cannot find ptlib - please install or set PTLIBDIR and try again

I tried setting PTLIBDIR and PWLIBDIR, but had no luck.

Is good to note that the system can see ptlib-config:

root at testbox_a:~# ptlib-config --version --libdir

Also, I tried doing:
touch /usr/include/ptlib/version.h , and after that, the configure 
script seems to go through without problem.

a. What I'm missing here?
b. What would be the possible consequences of creating an empty
    version.h, using 'touch'? (Will with break something?)

Sorry if any of this questions sounds obvious to you, I could not find 
any README or INSTALL doc inside sources packages.

Jose P. Espinal
IRC: Khratos @ #asterisk / -doc / -bugs

More information about the h323plus mailing list