[h323plus] [Opalvoip-devel] error H.263

Simon Horne s.horne at packetizer.com
Mon Feb 7 17:31:26 EST 2011


Vladimir

 

There are variations in the plugin architecture between Opal and H323plus.
Hence why I did not supply the actual plugin files. I can confirm that the
h264 h323plus plugin (with h239) works without issue.  I have seen issues
with the H.263+ implementation (originally from Opal) and why the old h.263
implementation (h263ffmpeg_pwplugin.dll) is still in the H323plus CVS which
includes the old FFMPEG binary (libavcodec.dll). 

 

Simon

 

From: Vladimir Fekete [mailto:vladko.fekete at gmail.com] 
Sent: 08 February 2011 03:40
To: ZAHRA dehghanianfard
Cc: h323plus at lists.packetizer.com; opal; opal
Subject: Re: [Opalvoip-devel] [h323plus] error H.263

 

Hello all,

 

 It is little bit off-topic, since it concerns OPAL 3.9.0 and above (e.g.
trunk from svn), but, I can confirm, that H.263 codec support can be nicely
without problems compiled under windows 7 32bit using VisualStudio2010
solution which is in OPAL 3.9.0 and above. (i did it). I tried also other
codecs one can found in plugin directory of OPAL. Also PTlib and OPAL itself
- both might be compiled directly from solution. 

 

Codec plugins  I was able to make run so far is (capability list from
openam):

 

   Cisco G.7231AR{sw} <1>

   Cisco G.7231A{sw} <2>

   G.711-ALaw-64k <3>

   G.711-uLaw-64k <4>

   G.723.1{sw} <5>

   H.261-CIF{sw} <6>

   H.261-QCIF{sw} <7>

   H.261{sw} <8>

   H.263-CIF{sw} <9>

   H.263-QCIF{sw} <10>

   H.263{sw} <11>

   H.239 Capabilities <12>

           H.263{sw} <1>

 

 however today I found out, that data transfer of H.263 is broken (looks
like broken paylod in rtp data stream). H.261 works fine (i was testing
openmcu together with openphone and myphone) and I could see this behavior
on both - "pure opal" applications as well as mixed opal/h323+ (yes I know
that opal uses h323+ or part of it). Right now I'm not entirely sure whether
it is caused by me or there is a bug. I have a plan to investigate it
further.

 

Concernig plugin files, I was able to compile in the end (e.g. what you get
from opal/plugins/ after build) :

 

 g7231acm_pwplugin.dll

 G726_ptplugin.dll

 h261vic_pwplugin.dll

 libavcodec.dll

 Vic H.261 Video Codec.lib

 ffmpeg H.263 Video Codec.lib

 h263ffmpeg_pwplugin.dll

 

I had to download ffmpeg and compile it as well in order to build opal
plugins for ffmpeg h263.

 

Concerning H264 plugin for OPAL - there is a problem around plugin-config.h
file. Project uses it but according to svn it is not supported anymore (at
least I saw the last one in OPAL 3.6.something (maybe even lesser version)
and after that it was deleted from svn tree), so one can have x264 build
under windows (which can be done also with little patience, but will have
problems with opal plugin). - that's so far my observation. 

 

Hope it helped!

 

Best regards,

 

   Vladimir

 

On Mon, Feb 7, 2011 at 12:01 PM, Simon Horne <s.horne at packetizer.com> wrote:

I think both the opal and h323plus community can benefit.

http://www.h323plus.org/source/download/ffmpeg_x264.zip

 

Place all files in your application directory.

The FFMPEG (with w32threads) and X264 is built with mingw/msys.
x264plugin_helper.exe is built with vs2008 and requires vs2008 runtime.

 

Simon

 

From: Robert Jongbloed [mailto:robertj at voxlucida.com.au] 
Sent: 07 February 2011 15:48
To: ZAHRA dehghanianfard
Cc: opal; opal
Subject: Re: [Opalvoip-devel] error H.263

 

The answer to your questions are:

 

1) Yes, but you need to compile it.

2) The result of compiling it is a DLL

3) You will have to figure out why it doesn't compile under windows.

 

 

I have to admit to not being able to get the H.263 (or x264) codecs to
compile and work under Windows, though I have only tried somewhat briefly.
Unfortunately the authors of all the libraries mainly use Linux, though it
is my understanding that it can be compiled using MinGW/Cygwin.

 

 

I am sure the OPAL community would be incredibly grateful to anyone that can
provide a pre-built binary for the H.263 (and x264!) codec.

 


--------

Robert Jongbloed

Vox Lucida Pty. Ltd.

 

 

 

On 03/02/2011, at 5:33 PM, ZAHRA dehghanianfard wrote:

 


Hi robert.

Many thanks for your last support; I need to use OpenPhone3.8.2 by H.263
codec run. 

1)      Is OpenPhone 3.8.2 with Opal 3.8.2 & Ptlib2.8.2 support H.263 codec
inside?

2)      If the above response is YES, Are you suggesting any H.263 DLL file?

3)      I find a source that name is "H.263-1998" then I download that and
compiles it but I find below Error inside:

 

1>------ Build started: Project: H.263-1998 (FFMPEG) Video Codec,
Configuration: Debug Win32 ------
1>Compiling...
1>h263pframe.cxx
1>c:\opal\plugins\video\h.263-1998\../common/ffmpeg.h(155) : fatal error
C1083: Cannot open include file: 'libavcodec\avcodec.h': No such file or
directory
1>h263-1998.cxx
1>c:\opal\plugins\video\h.263-1998\../common/ffmpeg.h(155) : fatal error
C1083: Cannot open include file: 'libavcodec\avcodec.h': No such file or
directory
1>Generating Code...
1>Build log was saved at
"file://c:\opal\plugins\Debug\H263-1998\BuildLog.htm
<file:///c:\opal\plugins\Debug\H263-1998\BuildLog.htm> "
1>H.263-1998 (FFMPEG) Video Codec - 2 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

 

I try to solve this problem by download a "libavcodec" that use some header
& DLL file that I copy in "C:\opal\plugin\video\common" but I take below
error:

 

 

1>------ Build started: Project: H.263-1998 (FFMPEG) Video Codec,
Configuration: Debug Win32 ------
1>Compiling...
1>h263pframe.cxx
1>c:\opal\plugins\video\h.263-1998\../common/ffmpeg.h(185) : fatal error
C1189: #error :  Libavcodec LIBAVCODEC_VERSION_INT too old.
1>h263-1998.cxx
1>c:\opal\plugins\video\h.263-1998\../common/ffmpeg.h(185) : fatal error
C1189: #error :  Libavcodec LIBAVCODEC_VERSION_INT too old.
1>Generating Code...
1>Build log was saved at
"file://c:\opal\plugins\Debug\H263-1998\BuildLog.htm
<file:///c:\opal\plugins\Debug\H263-1998\BuildLog.htm> "
1>H.263-1998 (FFMPEG) Video Codec - 2 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ========== 

 

Please guide me to i can have H.263 codec with DLL & source over OpenPhone
3.8.2 here.

I am in wait for your response.

Best Regards.

Zahra. 


----------------------------------------------------------------------------
--
Special Offer-- Download ArcSight Logger for FREE (a $49 USD value)!
Finally, a world-class log management solution at an even better price-free!
Download using promo code Free_Logger_4_Dev2Dev. Offer expires 
February 28th, so secure your free ArcSight Logger TODAY! 
http://p.sf.net/sfu/arcsight-sfd2d__________________________________________
_____
Opalvoip-devel mailing list
Opalvoip-devel at lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/opalvoip-devel

 

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.packetizer.com/pipermail/h323plus/attachments/20110208/eb67209e/attachment.htm>


More information about the h323plus mailing list