[h323plus] Configure problem?

Jan Willamowius jan at willamowius.de
Wed Aug 11 09:29:01 EDT 2010


Francisco,

the file plugins/aclocal.m4 needs to be created.
If you can provide a patch to run aclocal automatically, I'll gladly
include it into the CVS.

Regards,
Jan

Francisco Olarte (M) wrote:
> With a fresh CVS h323plus checkout configure emits
> 
> ERROR: you must first run 'aclocal' in /home/folarte/tmp/h323plus/plugins
> 
> It's trivial to solve, just '(cd plugins && aclocal)' solves it, but I
> wonder why I have this message.
> 
> The log of what I did is at end.
> 
> Regards.
>    Francisco Olarte.
> 
> --- LOG, PTlib 2.8.2 compiled & installed with prefix=$HOME, h323plus
> checked out from cvs
> 
> ( OS is
> 
> 
> folarte at gkaps ~/tmp/h323plus $    export PTLIBDIR=~/src/ptlib-2.8.2
> folarte at gkaps ~/tmp/h323plus $    export PWLIBDIR=$PTLIBDIR
> folarte at gkaps ~/tmp/h323plus $ ./configure --prefix=$HOME \
> >  --disable-h46018 \
> >  --disable-h46023 \
> >  --disable-mysql \
> >  --disable-pgsql \
> >  --disable-firebird \
> >  --disable-unixodbc \
> >  --disable-sqlite \
> >  --disable-radius
> checking for g++... g++
> checking for C++ compiler default output file name... a.out
> checking whether the C++ compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C++ compiler... yes
> checking whether g++ accepts -g... yes
> checking for gcc... gcc
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ISO C89... none needed
> checking how to run the C preprocessor... gcc -E
> checking for grep that handles long lines and -e... /bin/grep
> checking for egrep... /bin/grep -E
> checking for ANSI C header files... yes
> OpenH323 version is 1.22.0
> checking for /home/folarte/src/ptlib-2.8.2/version.h... yes
> PTLib prefix set to.... /home/folarte/src/ptlib-2.8.2
> checking Checking PTLib version 2.8.2... ok
> configure: Disabling H.350
> configure: Disabling H.460.18/.19
> configure: Disabling H.460.23/.24
> configure: Enabling T.38
> configure: Disabling GnuGk
> checking for a BSD-compatible install... /usr/bin/install -c
> configure: creating ./config.status
> config.status: creating openh323u.mak
> config.status: creating Makefile
> config.status: creating include/openh323buildopts.h
> === configuring in plugins (/home/folarte/tmp/h323plus/plugins)
> configure: running /bin/sh ./configure --disable-option-checking
> '--prefix=/home/folarte'  '--disable-h46018' '--disable-h46023'
> '--disable-mysql' '--disable-pgsql' '--disable-firebird'
> '--disable-unixodbc' '--disable-sqlite' '--disable-radius'
> --cache-file=/dev/null --srcdir=.
> ERROR: you must first run 'aclocal' in /home/folarte/tmp/h323plus/plugins
> 
> folarte at gkaps ~/tmp/h323plus $ uname -a
> Linux gkaps 2.6.34-gentoo-r1 #1 SMP Wed Jul 21 13:57:48 CEST 2010
> x86_64 Intel(R) Xeon(R) CPU E5530 @ 2.40GHz GenuineIntel GNU/Linux
> 
> folarte at gkaps ~/tmp/h323plus $ gcc -v
> Using built-in specs.
> Target: x86_64-pc-linux-gnu
> Configured with:
> /var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/gcc-4.4.3/configure
> --prefix=/usr --bindir=/usr/x86_64-pc-linux-gnu/gcc-bin/4.4.3
> --includedir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.3/include
> --datadir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.3
> --mandir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.3/man
> --infodir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.3/info
> --with-gxx-include-dir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.3/include/g++-v4
> --host=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu
> --disable-altivec --disable-fixed-point --without-ppl --without-cloog
> --enable-nls --without-included-gettext --with-system-zlib
> --disable-checking --disable-werror --enable-secureplt
> --enable-multilib --disable-libmudflap --disable-libssp
> --disable-libgomp
> --with-python-dir=/share/gcc-data/x86_64-pc-linux-gnu/4.4.3/python
> --disable-libgcj --enable-languages=c,c++ --enable-shared
> --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu
> --with-bugurl=http://bugs.gentoo.org/ --with-pkgversion='Gentoo
> 4.4.3-r2 p1.2'
> Thread model: posix
> gcc version 4.4.3 (Gentoo 4.4.3-r2 p1.2)
> 


-- 
Jan Willamowius, jan at willamowius.de, http://www.gnugk.org/



More information about the h323plus mailing list