[h323plus] Question about plugin codecs

Simon Horne s.horne at packetizer.com
Tue Jan 15 06:06:57 EST 2008


MFC is not very plugin friendly but I am glad you got it to work. It seems to ignore all attempt to load the plugins that is why you need the pluginloader in MyPhone2.
CVideoOutput device fix would be greatly appreciated. Then we can release it with the next stable release.

Simon
  -----Original Message-----
  From: h323plus-bounces at lists.packetizer.com [mailto:h323plus-bounces at lists.packetizer.com]On Behalf Of JF NP
  Sent: Tuesday, January 15, 2008 6:28 PM
  To: h323plus at lists.packetizer.com
  Subject: Re: [h323plus] Question about plugin codecs


  Hi,
    
  When I said "all works fine", I refered to the loading of plugins, I have not tested Myphone2 with a videocall, so I have not seen the bug on CVideoOutputDevice. BTW, thank you Simon for your help regarding my OCX (MFC) problem. Now, all the plugins are loaded.

  Anyway, if I can solve the CVideoOutputDevice bug, I will contribute the solution to the community.

  Best regards,


  ----- Mensaje original ----
  De: Simon Horne <s.horne at packetizer.com>
  Para: JF NP <jfnp090274 at yahoo.es>; h323plus at lists.packetizer.com
  Enviado: viernes, 11 de enero, 2008 9:55:38
  Asunto: RE: [h323plus] Question about plugin codecs


  What type of OCX is it? MFC or ATL. Its important as they behave differently with plugins. The problem is that the default directory for Ptlib when using COM (.ocx) is the desktop. Which is really annoying. 

  In ATL you need to do the following in your H323EndPoint contructor

  PPluginManager & pluginMgr = PPluginManager::GetPluginManager();
  pluginMgr.LoadPluginDirectory(pluginDir);

  This will load the plugins from that directory.

  If you are using MFC as with the case of MyPhone2 then there is a little more complicated so look at MyPhone2's CMyPhoneEndPoint() constructor to see how the plugins are loaded.

  Also you mentioned that you have MyPhone2 working with PtLib. Currently the CVS's MyPhone2 CVideoOutputDevice class is broken and does not display the video output correctly. It's a know problem that I have not yet got around to fixing. A small contribution back to the project on this would be appreciated for the benefit of the community. 

  Simon



  -----Original Message-----
  From: h323plus-bounces at lists.packetizer.com [mailto:h323plus-bounces at lists.packetizer.com]On Behalf Of JF NP
  Sent: Friday, January 11, 2008 12:30 AM
  To: h323plus at lists.packetizer.com
  Subject: [h323plus] Question about plugin codecs


  Hi all,

  I have successfully compiled both PTLib and H323Plus on Windows. I've also compiled and tested MyPhone2. All goes fine. But I have another sample app written by myself that is an OCX (which links with PTLib and H323Plus) that manages all the H323 stuff and an EXE that uses the OCX to make a simple videocall. The problem is that my app cannot find the plugin codecs (neither audio nor video). I think that the problem could be related to the fact that I am using an OCX linked with PTLib, instead of an EXE. Is this correct? Is there any solution or workaround?

  Best regards,





  Web Revelación Yahoo! 2007:
  Premio Favorita del Público - ¡Vota tu preferida!






------------------------------------------------------------------------------

  Web Revelación Yahoo! 2007:
  Premio Favorita del Público - ¡Vota tu preferida!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.packetizer.com/pipermail/h323plus/attachments/20080115/66a8ad4a/attachment.htm>


More information about the h323plus mailing list